Windows Server 2003 R2 läuft unter ESXi 5.5 nicht mehr

Wir haben unsere Vmware Hypervisoren vor kurzem auf die Version 5.5 aktualisiert. Seltsamerweise ergab sich dabei das Problem, dass auf einem System (nicht auf den anderen) danach keine Guests unter Windows Server 2003 R2 mehr nutzbar waren. Dabei spielte es keine Rolle, ob es sich um 32- oder 64-Bit-Systeme handelte. Beim Versuch, den jeweiligen Guest zu starten, blieb der Bildschirm schwarz. Drückte man rechtzeitig die „F8“-Taste, konnte man zwar das Startmenü aufrufen, danach passierte aber auch nichts mehr, egal welchen Eintrag („Abgesicherter Modus“, „Letzte als funktionieren bekannte Konfiguration“ und so weiter) man auswählte. Die CPU-Last der Guests lag immer bei 100 Prozent und der Arbeitsspeicher wurde zu Beginn relativ viel genutzt, diese Nutzung ging aber im Lauf der Zeit stufenweise bis auf Null zurück. Derselbe Fehler trat auch beim Versuch auf, die Guests mit Hilfe der Windows-Installations-CD zu analysieren. Der Boot-Vorgang von CD brach ebenfalls sofort ab, sogar in neu angelegten virtuellen Maschinen mit den Default-Vorgaben.

Eine Analyse der Log-Dateien eines der betroffenen Guest-Systeme brachte das Ergebnis, dass das Problem mit dem verwendeten virtuellen SCSI-Controller vom Typ „LSI Logic Parallel“ zusammenhing. Nachdem wir den Typ des virtuellen SCSI-Controllers in „BusLogic Parallel“ geändert hatten, liefen die Guests wieder. Bei x64-Systemen wird allerdings der BusLogic-Controller nicht unterstützt, hier half es nur, die Festplatte in ein IDE-Gerät umzuwandeln. Danach lief aber auch dieses System. Warum der Fehler auftrat, und das auch nur auf einem Hypervisor, ist aber weiter unklar.

[subscribe2]